Paint problem

Ratrod3347

New Member
Joined
Jan 27, 2016
Messages
11
Reaction score
0
Well here goes. I have some parts I have de-chromed with bleach.This is the first time have ever taken chrome off of parts.Now I believe I should be able to prime them now but I cant.... It won't stick.It looks like the parts are painted black under the chrome coating almost like a mattalic black.....did I do this process wrong or have missed something.is there something else on them I need to strip off?Thanks for any help
 

Elm City Hobbies

Active Member
Joined
May 7, 2009
Messages
3,233
Reaction score
2
Normally the parts under the chrome are the same color plastic as the kit, not always, but most times.

The parts could have a clear coat placed on the parts, between the plastic and the chrome coating, but this shouldn't affect a primer coat.

Did you use pure bleach? Or some thing that is a solution with bleach in it? Take and run your parts in warm water with a bit of dish soap, and gently scrub the parts with an old toothbrush, there could be a build up of something on the parts from the bleaching process that is preventing the primer to stick.

I am assuming you are using an acrylic primer?
 

Ratrod3347

New Member
Joined
Jan 27, 2016
Messages
11
Reaction score
0
Yea I'm using an acrylic primer.I let the parts soak In water for about an hour and scrubbed them with a brush. Did not seam to work but sanding them has but its really gumming up the paper like its a clear coat.
 

Elm City Hobbies

Active Member
Joined
May 7, 2009
Messages
3,233
Reaction score
2
Yeah, depending on the kit, they put a clear lacquer over the bare plastic, to give the chrome something to bite into.

I generally don't bother priming the chrome parts after I strip the chrome off, just hit it with a gloss black and then chrome.
 
Top